Puppet 0.25.1 Released!

This post is a little late… but. Puppet 0.25.1 - code name “zoot” - is now available. The 0.25.1 release is a maintenance release in the 0.25.x branch. The release is available via tarball and gem. Please report issues and feedback via the Reductive Labs Redmine site: Please select an affected version of 0.25.1. RELEASE NOTES * We’ve clarified that the new ‘require’ function only works for 0.25.x clients. If the function is specified with 0.24.x or earlier clients the class will be included but the inherent dependency will not be created. A warning message will be generated informing you of this. * Node regular expression matching rules have been clarified. * The Nagios serviceescalation type now supports the use of the servicegroup_name attribute. * The Puppet gem now installs all binaries to the ‘bin’ directory because Gems lack support for both a ‘bin’ and ‘sbin’ directory. Facter (version later than 1.5.1) is now also a dependency for the gem. * The zone type now works with OpenSolaris * You can now specify null values for environment variables in the cron type * The Vim syntax highlighting now identifies new regex structures CHANGELOG * Bug #1538: Yumrepo sets permissions wrongly on files in /etc/yum.repos.d * Bug #1719: Puppetd runtime increase dramaticilly after upgrading to 24.6 * Bug #1742: –color accepts parameters other than true, false, ansi,html - but produces “nil” output * Bug #1900: Parsing of quoted $ in stdin * Bug #1908: cron environment does not allow empty values * Bug #2508: misleading error about ActiveRecord versions * Bug #2534: Parser should raise an error if you specify the same property twice * Bug #2600: Master under mongrel wrong number of arguments (3 for 2) * Bug #2601: fqdn_rand raises exception when passed a seed * Bug #2605: Ruby 1.8.1 compatibility - #1963 fix uses method not in 1.8.1 * Bug #2606: Gems can’t handle binaries in the sbin directory * Bug #2607: 0.25 gem does not have facter as a dependency * Bug #2608: install.rb will not run on ruby 1.9.1 due to ftools being deprecated * Bug #2612: vim syntax highlighting of new regex language features * Bug #2613: Autorequire fails when a directory’s path has a trailing / * Bug #2615: YAML sometimes modifies the contents of string data * Bug #2616: Locking error in tagmail * Bug #2618: Spurious test falures when testing redhat service providers on debian varients * Bug #2619: Fresh 0.25.0 client cannot ‘authenticate’ to 0.25.0 puppetmaster. * Bug #2620: Regex problem in puppetmaster auth.conf * Bug #2621: possible JSon serialization issue (on debian/lenny/amd64) * Bug #2622: puppetdoc returns undefined method ‘[]’ * Bug #2626: Unhelpful error message * Bug #2627: Node regular expressions only work in some cases * Bug #2632: require doesnt seem to work * Bug #2634: nagios type serviceescalation should support servicegroup_name * Bug #2637: SSL socket race condition under webrick * Bug #2638: inconsistent behaviour when more than one “node /foo/ { }” stanza matches. * Bug #2639: Fail to store reports in simple default config * Bug #2640: runit service provider does not create symlinks * Bug #2642: runit service provider doesn’t have a restart command * Bug #2648: macauthorization provider spuriously changes values when not needed. * Bug #2651: Directory permissions on man pages can be incorrect * Bug #2652: syntax error in lib/puppet/util/selinux.rb according to Fedora 11 ruby 1.8.6 * Bug #2654: Confusing error message when a provider lacks a feature * Bug #2656: Puppet –parseonly tests hang forever * Bug #2661: puppetd exits if the master is unreachable. * Bug #2664: regexp parse error * Bug #2665: regex problem with package names containing ++ * Bug #2668: Too many facts: request-URI Too Large * Bug #2672: Cannot have underscores in node name * Bug #2674: createpackage.sh: problem finding install.rb * Bug #2676: lib/puppet/agent.rb apparent typo * Bug #2679: Possible regression * Bug #2681: “Duplicate generated resource;skipping” for each managed resource * Bug #2685: Got an uncaught exception of type TypeError * Bug #2686: ActiveSupport >= 2.3.3 forces use of defective JSON library * Bug #2688: macauthorization provider now doesn’t deal with booleans correctly. * Bug #2689: Running puppet as non- root => getting rid of all those ownership warnings * Bug #2691: “Could not retrieve catalog: HTTP-Error: 500 Internal Server Error” with tagged exported resources * Bug #2697: provider/portage.rb: update-eix is deprecated * Bug #2698: provider/portage.rb: format string has changed (again) * Bug #2699: Configurable port in the included Red Hat init script is broken * Bug #2702: puppetdoc rdoc mode fails if outputdir not specified * Bug #2707: ‘config_version’ should behave better on failure * Bug #2711: Storeconfigs don’t work with puppet command * Bug #2734: classfile is only 1 byte big * Bug #2735: External node classes aren’t added to the class list on compile startup * Bug #2736: Ssh_authorized_key target changed? * Bug #2737: The zone provider needs to get acquainted with OpenSolaris * Bug #2739: puppetmasterd 0.25.1rc2 is not logging anywhere * Bug #2745: fakedata iteration in specs is borked. * Bug #2750: puppetd: setting the :cacrl to ‘false’ is deprecated * Bug #2751: Red Hat initscripts kill an independently started puppetd/puppetmasterd * Bug #2752: require function does not work in ‘puppet’ * Bug #2753: fileserver.conf allow/deny directives not honored for [modules], [plugins] * Feature #2393: We should maintain a dynamically-built ‘next’ branch

comments powered by Disqus